Support Center

Problems in night scenes

Jan 23, 2014

There are three general categories of cause false alerts or recognition errors found in night scenes:

  • False alerts caused by sudden light changes. If a bright light is turned on of off in a very dark scene, the visual characteristics of the software may be confused into thinking an object is present.
  • False alerts caused by "video noise." Some cameras generate a pixelated image in low light situations. Even though the general scene is dark, the software may register the pixel artifacts as edges of objects.
  • False alerts, or boxes around actual objects, that persist for long periods of time ("Stuck boxes"). This is an uncommon case but has been reported.

Tips and workarounds:

  • The most effective solution is to provide better lighting, if that is possible. A small amount of light can make a significant difference.
  • If the false alerts are labeled as "unknowns" (outlined in green) rather than as "people" (outlined in yellow), you can set up your rule to filter on "people"only. This of course won't help if you are seeing light changes labeled as people, or are trying to track other objects such as animals.
  • Different cameras produce very different images at night. Axis cameras, for example, tend to have fairly noisy pixels in scenes with very low light (although they can also generate clearer images in relatively low light). Below are some suggestions that might make the video stream less noisy, and therefore have it generate less "moving objects" in low light. Your camera may have similar settings.
    • Try editing your camera configuration settings in Sighthound Video.
      • Select your camera in the Monitor view.
      • Select Edit Camera... from the Tools menu.
      • Click Next until you get to the screen that says "Enter settings to allow Sighthound Video to access your camera."
      • Change the Camera type setting to Axis (other MPEG-4 - type A).
    • You may get better night results by changing some settings on your camera.
      • Use the Axis software and go into the "Video & Audio"settings,
      • Go to "Camera Settings" and choose "Motion" as the "Exposure priority."
      • Try 1/5000s for min shutter, 1/4s for max shutter, 0 for min gain and 32 for max gain.
    • It's possible that changing the MPEG4 bit rate from the camera (under "Video & Audio", "MPEG-4 and H.264") will help. A value of constant bit rate value of 1000 is probably reasonable to try, but you could try things between 700 and 2000. Lower bit rates probably will help "noisy video" problems.