Close

ELP Camera disconnecting

Inquire about an unsupported model or post your own success.

Moderator: Staff

no avatar
dpetrillo
 
Posts: 1
Joined: Wed Nov 02, 2016 2:41 pm

ELP Camera disconnecting

by dpetrillo » Wed Nov 02, 2016 2:48 pm

Hello,

I submitted a bug report for this but I figured I would post here also, feel free to delete if necessary. I am currently evaluating a pro licence.

I bought a cheap IP camera that isn't officially supported. http://www.elpcctv.com/720p-hd-mini-dom ... -p-50.html It's available on Amazon for $30. I got it working using ONVIF. It becomes disconnected from sighthound from time to time. The feed is still available but sighthound will not reconnect. I am on Windows 7. Log below.

Code: Select all
2016-11-01 11:10:38,523 - INFO - StreamReader.pyo - open - Attempting to open camera at
2016-11-01 11:10:38,523 - ERROR - StreamReader.pyo - open - videolib: Failed to open  err=-2
2016-11-01 11:10:38,523 - ERROR - StreamReader.pyo - open - videolib: Failed to open stream object 0x2c6ad8
2016-11-01 11:10:38,525 - ERROR - StreamReader.pyo - open - Failed to open stream context res=-4
2016-11-01 11:10:38,525 - ERROR - StreamReader.pyo - open - Failed to open camera at
2016-11-01 11:10:39,025 - INFO - StreamReader.pyo - open - Attempting to open camera at
2016-11-01 11:10:39,025 - ERROR - StreamReader.pyo - open - videolib: Failed to open  err=-2
2016-11-01 11:10:39,025 - ERROR - StreamReader.pyo - open - videolib: Failed to open stream object 0x2c6ad8
2016-11-01 11:10:39,026 - ERROR - StreamReader.pyo - open - Failed to open stream context res=-4
2016-11-01 11:10:39,026 - ERROR - StreamReader.pyo - open - Failed to open camera at
2016-11-02 14:33:14,006 - INFO - r16019xW_100S115.pyo - __init__ - Camera capture initialized
2016-11-02 14:33:14,019 - INFO - r16019xW_100S115.pyo - r16019yW_100l025 - Beginning stream open
2016-11-02 14:33:14,019 - INFO - StreamReader.pyo - open - Attempting to open camera at rtsp://xxxxx@xxx.xxx.x.x:xxx/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp?real_stream
2016-11-02 14:33:14,020 - INFO - StreamReader.pyo - open - videolib: Opening rtsp://u:p@xxx.xxx.x.x:xxx/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp?real_stream using UDP for transport (streamId=0)
2016-11-02 14:33:14,131 - INFO - StreamReader.pyo - open - videolib: Initiate the "video/H264" subsession (client port 64920)
2016-11-02 14:33:14,131 - INFO - StreamReader.pyo - open - videolib: Setting socket buffer to 6291456
2016-11-02 14:33:14,171 - INFO - StreamReader.pyo - open - videolib: Set up the "video/H264" subsession (client port 64920)
2016-11-02 14:33:14,171 - INFO - StreamReader.pyo - open - videolib: Created a data sink for the "video/H264" subsession
2016-11-02 14:33:14,305 - INFO - StreamReader.pyo - open - videolib: Started playback on "[URL:"rtsp://u:p@xxx.xxx.x.x:xxx/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp/"]" session
2016-11-02 14:33:14,558 - INFO - StreamReader.pyo - open - Opened stream: uri=rtsp://u:p@xxx.xxx.x.x:xxx/user=admin_password=tlJwpbo6_channel=1_stream=0.sdp?real_stream, w=1280, h=720, buf=0
2016-11-02 14:33:14,559 - INFO - StreamReader.pyo - open - Opening local codec libx264 H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (28), 320x180
2016-11-02 14:33:14,584 - INFO - StreamReader.pyo - open - Created conversion context in=1280x720 out=320x180
2016-11-02 14:33:14,585 - INFO - r16019xW_100S115.pyo - r16019yW_100l025 - Stream open successful
2016-11-02 14:33:14,585 - INFO - StreamReader.pyo - r16019yW_1001151 - Starting camera read loop...

Return to Unsupported Cameras